Quantcast

Amazon LinuxのGUI化について

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Amazon LinuxのGUI化について

TKHI
初めまして、TKHIと申します。

Amazon LinuxのGUI化でかなりてこずっています。

Amazon LinuxをGUI化し、windowsからVNCで接続したいと考えています。

以下のURLを参考に、Amazon LinuxにCentOSのリポジトリを追加してvnc-serverをインストールしようとしたのですが、エラーがでてうまく動きません。
http://d.hatena.ne.jp/pellosh/20110310/1299772536

以下が実行結果です。
---------------------

[root@ip-10-156-179-60 yum.repos.d]# yum install vnc-server
Loaded plugins: fastestmirror, priorities, security, update-motd
Loading mirror speeds from cached hostfile
 * amzn-main: packages.ap-northeast-1.amazonaws.com
 * amzn-updates: packages.ap-northeast-1.amazonaws.com
2786 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package tigervnc-server-module.x86_64 0:1.0.90-0.17.20110314svn4359.el6 will be installed
--> Processing Dependency: xorg-x11-server-Xorg for package: tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
--> Running transaction check
---> Package gnutls.x86_64 0:2.8.5-4.6.amzn1 will be installed
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: gnutls-2.8.5-4.6.amzn1.x86_64
--> Processing Dependency: libtasn1.so.3()(64bit) for package: gnutls-2.8.5-4.6.amzn1.x86_64
---> Package xorg-x11-server-Xorg.x86_64 0:1.10.4-6.el6 will be installed
--> Processing Dependency: libdrm >= 2.4.20 for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: xorg-x11-drv-evdev >= 2.1.0-3 for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: xorg-x11-server-common >= 1.10.4-6.el6 for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: fedora-setup-keyboard for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: xorg-x11-drv-void for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: xorg-x11-drv-vesa for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libdrm.so.2()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libXfont.so.1()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libpciaccess.so.0()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libhal.so.1()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Processing Dependency: libXdmcp.so.6()(64bit) for package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
--> Running transaction check
---> Package hal-libs.x86_64 0:0.5.14-11.el6 will be installed
---> Package libXdmcp.x86_64 0:1.0.3-1.7.amzn1 will be installed
---> Package libXfont.x86_64 0:1.4.1-2.6.amzn1 will be installed
--> Processing Dependency: libfontenc.so.1()(64bit) for package: libXfont-1.4.1-2.6.amzn1.x86_64
---> Package libdrm.x86_64 0:2.4.25-2.el6 will be installed
---> Package libpciaccess.x86_64 0:0.12.1-1.el6 will be installed
---> Package libtasn1.x86_64 0:2.3-3.4.amzn1 will be installed
---> Package pixman.x86_64 0:0.18.4-1.5.amzn1 will be installed
---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
--> Processing Dependency: hal for package: system-setup-keyboard-0.7-4.el6.x86_64
---> Package xorg-x11-drv-evdev.x86_64 0:2.6.0-2.el6 will be installed
--> Processing Dependency: xkeyboard-config >= 1.4-1 for package: xorg-x11-drv-evdev-2.6.0-2.el6.x86_64
---> Package xorg-x11-drv-vesa.x86_64 0:2.3.0-2.el6 will be installed
---> Package xorg-x11-drv-void.x86_64 0:1.4.0-1.el6 will be installed
---> Package xorg-x11-server-common.x86_64 0:1.10.4-6.11.amzn1 will be installed
--> Processing Dependency: xkbcomp for package: xorg-x11-server-common-1.10.4-6.11.amzn1.x86_64
--> Running transaction check
---> Package libfontenc.x86_64 0:1.0.5-2.6.amzn1 will be installed
---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
--> Processing Dependency: hal for package: system-setup-keyboard-0.7-4.el6.x86_64
---> Package xkeyboard-config.noarch 0:2.3-1.5.amzn1 will be installed
---> Package xorg-x11-xkb-utils.x86_64 0:7.4-6.7.amzn1 will be installed
--> Processing Dependency: libxkbfile.so.1()(64bit) for package: xorg-x11-xkb-utils-7.4-6.7.amzn1.x86_64
--> Running transaction check
---> Package libxkbfile.x86_64 0:1.0.6-1.1.6.amzn1 will be installed
---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
--> Processing Dependency: hal for package: system-setup-keyboard-0.7-4.el6.x86_64
--> Finished Dependency Resolution
Error: Package: system-setup-keyboard-0.7-4.el6.x86_64 (base)
           Requires: hal
           Available: hal-0.5.14-11.el6.x86_64 (base)
               hal = 0.5.14-11.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@ip-10-156-179-60 yum.repos.d]#

---------------------

追加したリポジトリcent.repoは以下のようになっています。

---
[base]
name=CentOS-base
baseurl=http://ftp.riken.jp/Linux/caos/centos/6.2/os/x86_64/
enabled=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
gpgcheck=1
priority=1
protect=1
---

halがないためだと思い、yum install halを実行後に再度試しましたが、同じ結果になりました。

色々試してみましたが、かれこれ1週間くらい先に進めていません。

この方法でなくて構いませんので、GUI化してVNCで接続する方法をご教授していただけないでしょうか。
よろしくお願いいたします。

Jin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[JAWS-users 0399] Re: Amazon LinuxのGUI化について

Jin
こんにちは、Jinux と申します。

Amazon Linux の場合、yum パッケージがあまり揃っていないので
他のディストリビューションのリポジトリを使って yum install することに
なりますが、うまく行かない場合もあるようです。
もし Amazon Linux でなくとも良いのであれば、下記いずれかの AMI
を選択すると楽かと思います。

選択1: 多少お金はかかっても良い場合
     Red Hat Enterprise Linux 6.2 x86_64
     ami-905ee991 (Quick Start タブに出てくるもの)

選択2: Red Hat 系を使いたいがお金はかけたくない場合
     CentOS 6.2 x86_64
     ami-aa289eab (Commuity AMIs タブから検索)

選択3: Ubuntu を使う場合
     Ubuntu Server 12.04 LTS x86_64
     ami-60c77761 (Quick Start タブに出てくるもの)

いずれもそのまま yum groupinstall や apt-get install で
X Window system や Desktop をインストールすることができました。
vncserver は、tigervnc-server(Red Hat系)か vnc4server
(Ubuntu)を使います。

いかがでしょうか?


2012/5/7 TKHI <[hidden email]>:

> 初めまして、TKHIと申します。
>
> Amazon LinuxのGUI化でかなりてこずっています。
>
> Amazon LinuxをGUI化し、windowsからVNCで接続したいと考えています。
>
> 以下のURLを参考に、Amazon
> LinuxにCentOSのリポジトリを追加してvnc-serverをインストールしようとしたのですが、エラーがでてうまく動きません。
> http://d.hatena.ne.jp/pellosh/20110310/1299772536
>
> 以下が実行結果です。
> ---------------------
>
> [root@ip-10-156-179-60 yum.repos.d]# yum install vnc-server
> Loaded plugins: fastestmirror, priorities, security, update-motd
> Loading mirror speeds from cached hostfile
>  * amzn-main: packages.ap-northeast-1.amazonaws.com
>  * amzn-updates: packages.ap-northeast-1.amazonaws.com
> 2786 packages excluded due to repository priority protections
> Setting up Install Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package tigervnc-server-module.x86_64 0:1.0.90-0.17.20110314svn4359.el6
> will be installed
> --> Processing Dependency: xorg-x11-server-Xorg for package:
> tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
> --> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package:
> tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
> --> Processing Dependency: libgnutls.so.26()(64bit) for package:
> tigervnc-server-module-1.0.90-0.17.20110314svn4359.el6.x86_64
> --> Running transaction check
> ---> Package gnutls.x86_64 0:2.8.5-4.6.amzn1 will be installed
> --> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package:
> gnutls-2.8.5-4.6.amzn1.x86_64
> --> Processing Dependency: libtasn1.so.3()(64bit) for package:
> gnutls-2.8.5-4.6.amzn1.x86_64
> ---> Package xorg-x11-server-Xorg.x86_64 0:1.10.4-6.el6 will be installed
> --> Processing Dependency: libdrm >= 2.4.20 for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: xorg-x11-drv-evdev >= 2.1.0-3 for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: xorg-x11-server-common >= 1.10.4-6.el6 for
> package: xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: fedora-setup-keyboard for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: xorg-x11-drv-void for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: xorg-x11-drv-vesa for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libpixman-1.so.0()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libdrm.so.2()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libXfont.so.1()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libpciaccess.so.0()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libhal.so.1()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Processing Dependency: libXdmcp.so.6()(64bit) for package:
> xorg-x11-server-Xorg-1.10.4-6.el6.x86_64
> --> Running transaction check
> ---> Package hal-libs.x86_64 0:0.5.14-11.el6 will be installed
> ---> Package libXdmcp.x86_64 0:1.0.3-1.7.amzn1 will be installed
> ---> Package libXfont.x86_64 0:1.4.1-2.6.amzn1 will be installed
> --> Processing Dependency: libfontenc.so.1()(64bit) for package:
> libXfont-1.4.1-2.6.amzn1.x86_64
> ---> Package libdrm.x86_64 0:2.4.25-2.el6 will be installed
> ---> Package libpciaccess.x86_64 0:0.12.1-1.el6 will be installed
> ---> Package libtasn1.x86_64 0:2.3-3.4.amzn1 will be installed
> ---> Package pixman.x86_64 0:0.18.4-1.5.amzn1 will be installed
> ---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
> --> Processing Dependency: hal for package:
> system-setup-keyboard-0.7-4.el6.x86_64
> ---> Package xorg-x11-drv-evdev.x86_64 0:2.6.0-2.el6 will be installed
> --> Processing Dependency: xkeyboard-config >= 1.4-1 for package:
> xorg-x11-drv-evdev-2.6.0-2.el6.x86_64
> ---> Package xorg-x11-drv-vesa.x86_64 0:2.3.0-2.el6 will be installed
> ---> Package xorg-x11-drv-void.x86_64 0:1.4.0-1.el6 will be installed
> ---> Package xorg-x11-server-common.x86_64 0:1.10.4-6.11.amzn1 will be
> installed
> --> Processing Dependency: xkbcomp for package:
> xorg-x11-server-common-1.10.4-6.11.amzn1.x86_64
> --> Running transaction check
> ---> Package libfontenc.x86_64 0:1.0.5-2.6.amzn1 will be installed
> ---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
> --> Processing Dependency: hal for package:
> system-setup-keyboard-0.7-4.el6.x86_64
> ---> Package xkeyboard-config.noarch 0:2.3-1.5.amzn1 will be installed
> ---> Package xorg-x11-xkb-utils.x86_64 0:7.4-6.7.amzn1 will be installed
> --> Processing Dependency: libxkbfile.so.1()(64bit) for package:
> xorg-x11-xkb-utils-7.4-6.7.amzn1.x86_64
> --> Running transaction check
> ---> Package libxkbfile.x86_64 0:1.0.6-1.1.6.amzn1 will be installed
> ---> Package system-setup-keyboard.x86_64 0:0.7-4.el6 will be installed
> --> Processing Dependency: hal for package:
> system-setup-keyboard-0.7-4.el6.x86_64
> --> Finished Dependency Resolution
> Error: Package: system-setup-keyboard-0.7-4.el6.x86_64 (base)
>           Requires: hal
>           Available: hal-0.5.14-11.el6.x86_64 (base)
>               hal = 0.5.14-11.el6
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> [root@ip-10-156-179-60 yum.repos.d]#
>
> ---------------------
>
> 追加したリポジトリcent.repoは以下のようになっています。
>
> ---
> [base]
> name=CentOS-base
> baseurl=http://ftp.riken.jp/Linux/caos/centos/6.2/os/x86_64/
> enabled=1
> gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
> gpgcheck=1
> priority=1
> protect=1
> ---
>
> halがないためだと思い、yum install halを実行後に再度試しましたが、同じ結果になりました。
>
> 色々試してみましたが、かれこれ1週間くらい先に進めていません。
>
> この方法でなくて構いませんので、GUI化してVNCで接続する方法をご教授していただけないでしょうか。
> よろしくお願いいたします。
>
_______________________________________________
JAWS-users mailing list
[hidden email]
http://jaws-ug.jp/mailman/listinfo/jaws-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [JAWS-users 0399] Re: Amazon LinuxのGUI化について

TKHI
ご返信ありがとうございます!

こんにちは、Jinux と申します。

Amazon Linux の場合、yum パッケージがあまり揃っていないので
他のディストリビューションのリポジトリを使って yum install することに
なりますが、うまく行かない場合もあるようです。
やはりそうなのですね。。

もし Amazon Linux でなくとも良いのであれば、下記いずれかの AMI
を選択すると楽かと思います。

選択1: 多少お金はかかっても良い場合
     Red Hat Enterprise Linux 6.2 x86_64
     ami-905ee991 (Quick Start タブに出てくるもの)

選択2: Red Hat 系を使いたいがお金はかけたくない場合
     CentOS 6.2 x86_64
     ami-aa289eab (Commuity AMIs タブから検索)

選択3: Ubuntu を使う場合
     Ubuntu Server 12.04 LTS x86_64
     ami-60c77761 (Quick Start タブに出てくるもの)

いずれもそのまま yum groupinstall や apt-get install で
X Window system や Desktop をインストールすることができました。
vncserver は、tigervnc-server(Red Hat系)か vnc4server
(Ubuntu)を使います。

いかがでしょうか?
ありがとうございます!

本当は選択2のCentOSを使用したいのですが、いろいろな事情があり、できればAmazon LinuxでGUI化したいと考えています。
方法はご存じないでしょうか。

お手数ですが、よろしくお願いいたします。
Loading...